Forum d'entraide à la création de jeux d'aventure
 
PortailAccueilFAQRechercherS'enregistrerMembresConnexion

Partagez | 
 

 [résolu]problème Vidéo/cinématique d'introduction dans la room1

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
adauca
Adepte de la Grande Tasse Bleue
Adepte de la Grande Tasse Bleue


Nombre de messages : 133

Age : 34

Localisation : Strasbourg

Date d'inscription : 10/02/2014


MessageSujet: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Lun 27 Avr 2015 - 21:22

Bonjour à tous,

voilà j'ai commencé la programmation de mon jeu Mad Day sur AGS 3.3.0. J'utilise aussi le plug-in "Custom Resolution build" afin de monter la résolution en HD 1920 x 1080.

Mon problème est le suivant:
J'ai ma vidéo en .avi non compressée (pour ma part, la seule compression qui fonctionne avec AGS...) que je scripte dans ma première room avec ces commandes :
Code:
function room_Load()
{
 PlayVideo("introduction.avi", 0,0);
}

Lorsque je test directement dans AGS avec RUN(F5) cela fonctionne plutôt bien.
Lorsque j'utilise le mode fenêtre de l'exe par l'intermédiaire du winsetup cela fonctionne également.
Mais là où ça pêche et là où j'aimerai justement que cela fonctionne, c'est le mode "normal" plein écran qui n'affiche qu'un écran noir sans rien qui se passe.

Est-ce que quelqu'un a déjà eu ce problème? Comment peut-on le résoudre? Peut-on seulement le résoudre?

merci d'avance

_________________
Une agence de publicité, c'est 85 % de confusion et 15 % de commission.


Dernière édition par adauca le Lun 4 Mai 2015 - 17:30, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.mad-day.fr
Billbis
Disciple de la Grande Tasse Bleue
Disciple de la Grande Tasse Bleue


Nombre de messages : 1275

Date d'inscription : 10/05/2012


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Lun 27 Avr 2015 - 21:34

Je ne sais pas pour ton problème, mais tu peux regarder du coté de la prochaine alpha d'AGS, avec lequel j'ai notamment fait Topus en 720p :
http://www.adventuregamestudio.co.uk/forums/index.php?topic=51050.0

Sinon, il faut que je fouille les vieux topic a propos de lecture de vidéo en plein écran...

_________________
Mon petit DevBlog
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nothingaboutthedog.blogspot.fr/
adauca
Adepte de la Grande Tasse Bleue
Adepte de la Grande Tasse Bleue


Nombre de messages : 133

Age : 34

Localisation : Strasbourg

Date d'inscription : 10/02/2014


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Lun 27 Avr 2015 - 21:50

J'ai pris connaissance de cette version mais j'attends plus de retours afin d'être sûr de pas planter mon projet en plein milieu...

Après si tu me dis que tu l'as utilisé sans problème pourquoi pas mais je ne pense pas que cela règlera mon problème. Il doit y avoir un problème de codecs.
Tu as fait des vidéos d'intro également?

_________________
Une agence de publicité, c'est 85 % de confusion et 15 % de commission.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.mad-day.fr
adauca
Adepte de la Grande Tasse Bleue
Adepte de la Grande Tasse Bleue


Nombre de messages : 133

Age : 34

Localisation : Strasbourg

Date d'inscription : 10/02/2014


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Lun 27 Avr 2015 - 22:13

En effet, je viens d'essayer avec AGS 3.4.0 alpha et même problème (avec d'autres en plus...)
Je ne trouve pas ce que ça peut-être.
J'ai essayé avec l'extension ogg mais c'est encore pire... Pourtant censé mieux fonctionner.

_________________
Une agence de publicité, c'est 85 % de confusion et 15 % de commission.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.mad-day.fr
Billbis
Disciple de la Grande Tasse Bleue
Disciple de la Grande Tasse Bleue


Nombre de messages : 1275

Date d'inscription : 10/05/2012


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Mar 28 Avr 2015 - 8:50

As-tu essayé de convertir ta vidéo en .OGV ?
D’après ce sujet, les .WMV ne se lancent pas en plein écran en mode Direct3D. Ils ne parlent pas des .AVI, mais ça vaut le coup d'essayer.

_________________
Mon petit DevBlog
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nothingaboutthedog.blogspot.fr/
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Mar 28 Avr 2015 - 9:33

adauca a écrit:
J'ai ma vidéo en .avi non compressée (pour ma part, la seule compression qui fonctionne avec AGS...)
Surprenant. Pour ma part, mes vidéos sont compressées en divx et je n'ai jamais eu de problème.

J'ai eu un soucis de vidéo d'intro que j'ai résolu comme suit : j'ai simple mis un fond noir à la taille de la résolution du jeu, dans la room de lancement de la vidéo. Celle-ci se lançait sans problème avec F5 mais avec .exe du jeu elle était décalée.

Je sais pas si ça peut t'aider ^^
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
adauca
Adepte de la Grande Tasse Bleue
Adepte de la Grande Tasse Bleue


Nombre de messages : 133

Age : 34

Localisation : Strasbourg

Date d'inscription : 10/02/2014


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Ven 1 Mai 2015 - 23:20

merci pour ces réponses. Voilà ce que je conclue de mon expérience (et ce que du coup j'arrive à faire).

Le format AVI, MPG et OGV fonctionnent bien en mode DirectDraw5 (défaut) dans les settings.
Par contre en Direct3D j'ai laissé tombé, rien ou presque qui fonctionne en mode plein écran lors de l'utilisation d'un .exe

Maintenant il s'agit de régler au mieux la compression et le format pour que ma vidéo soit légère tout en étant de qualité satisfaisante.
Finalement comme je disais plus haut, pour moi, le .avi est le meilleur compromis et diviser la résolution pour la rendre plus légère et l'étirer en mode plein écran est ma solution finale pour le moment.

Voilà, je cherche encore un peu et si jamais j'ai une solution plus convenable je vous tiens au courant!


_________________
Une agence de publicité, c'est 85 % de confusion et 15 % de commission.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.mad-day.fr
Kitai
Délégué de la tasse bleue
Délégué de la tasse bleue


Nombre de messages : 2431

Date d'inscription : 01/08/2006


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Sam 2 Mai 2015 - 3:32

Merci pour ce retour adauca, et heureux d'apprendre que tu as trouvé une solution (même si elle n'est peut-être pas idéale). C'est vrai que AGS semble avoir pas mal de problèmes avec Direct3D, j'ai l'impression qu'il gère beaucoup mieux DirectDraw de façon générale.
Oublie pas de mettre ce réglage par défaut et de laisser une note au joueur quelque part à ce propos.

_________________
Ga is Ga
Vous pouvez consulter l'aide d'AGS 3.2 en français et contribuer à la traduction et à l'amélioration si le cœur vous en dit !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://admin.no.uchi.free.fr/dokuwiki-2008-05-05/doku.php
adauca
Adepte de la Grande Tasse Bleue
Adepte de la Grande Tasse Bleue


Nombre de messages : 133

Age : 34

Localisation : Strasbourg

Date d'inscription : 10/02/2014


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Lun 4 Mai 2015 - 17:30

Alors, après maintes recherches j'ai trouvé le moyen d'avoir du .avi d'excellente qualité sans réduire le format. Je passe d'une sortie after effects de 6 Go à 12 Mo avec virtualdub.

Je donne les grandes lignes car je pense que pas mal de monde connait l'astuce:
Télécharger virtualdub (gratuit).
Puis ce plug-in xvid qui permettra de compresser la vidéo sur virtualdub (open source).

Décompresser virtualdub où vous voulez et installer le plug-in. Ensuite ouvrez virtualdub, insérez votre vidéo .avi et allez dans l'onglet "video" et choisissez XVid MPEG-4 Codec (gardez les réglages à 4.00). Ensuite allez dans l'onglet "File" et choisissez "save old format AVI" en l'appelant autrement. Et c'est fini.

La qualité est intacte (à l'oeil) et votre vidéo est ultra légère.

Voilà, j'espère pouvoir aider quelqu'un et apporter quelque chose d'utile. Si vous avez d'autres questions, j'essaierai tant bien que mal d'y répondre.

Je clos du coup ce post, mais reste à l'écoute sourire

_________________
Une agence de publicité, c'est 85 % de confusion et 15 % de commission.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.mad-day.fr
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Lun 4 Mai 2015 - 18:18

Merci du retour grand sourire car la compression vidéo c'est toujours une vrai gagure perplexe

Il est vrai qu'on oublie souvent Xvid. Je testerai ça aussi clin d\\\\'oeil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
hanakin
Cliqueur Amateur
Cliqueur Amateur


Nombre de messages : 488

Age : 51

Localisation : Angers

Date d'inscription : 12/09/2012


MessageSujet: reVideo   Sam 9 Mai 2015 - 22:46

Il est vrai que la vidéo c'est pas évident , garder une bonne qualité tout en ayant un fichier pas trop gros ça ce calcul. Je m'étais fait un petit soft en VB dans ce but (j'utilise aussi virtualDub ) si cela interresse quelq'un il est ici:

http://dinomania.chez-alice.fr/CalculVideo.zip

Perso j'utilise toujours Xvid plutot que DivX ou divers autres compresseurs..
Surtout lors d'une compression c'est d'utiliser 2 passes et non une seule c'est tres important
pour avoir une qualité optimum.

_________________
Ce qui est utile à beaucoup l'emporte sur les désirs du petit nombre. (Spock)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dinomania.chez-alice.fr/index.htm
Contenu sponsorisé




MessageSujet: Re: [résolu]problème Vidéo/cinématique d'introduction dans la room1   Aujourd'hui à 19:14

Revenir en haut Aller en bas
 
[résolu]problème Vidéo/cinématique d'introduction dans la room1
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [RESOLU] Problème zoom niveau cinématique.
» Cinématique d'intro BC !
» Wrath of the Lich King - Cinématique d'introduction
» [Résolu]Aide pour affrontement en cinématique "event"
» Comment faire un cinématique? [résolu]

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Adventure Games Studio fr :: CREATION DE JEUX :: Questions / Réponses-
Sauter vers: