Forum d'entraide à la création de jeux d'aventure
 
PortailAccueilFAQRechercherS'enregistrerMembresConnexion

Partagez | 
 

 [résolu]Musique qui ne se lance pas

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: [résolu]Musique qui ne se lance pas   Jeu 26 Fév 2015 - 20:01

Bonjour à tous et à toutes,

Pour mon premier test/apprentissage du codage de jeu/découverte d'AGS 3.3.0, j'ai suivi les tutos. Rien de bien nouveau, ils sont clairs et précis, les indications sont faciles à suivre et à comprendre.
Jusqu'au moment où j'arrive aux musiques. J'ai lu le tuto de Shai-La ainsi que celui parlant de la "refonte audio" de la nouvelle version et l'aide en ligne.

Malgré cela, et plusieurs tests, la musique ne se lance pas. Le son fonctionne mais pour mettre la musique dans la pièce où le personnage apparaît, c'est une galère. Ne connaissant pas les fonctions et autres variables, le pif-o-mètre me semblait à écarter (de toute manière, le programme me le disait, dès que je faisais une bêtise qu'il n'appréciait pas).

Pour résumer : comment mettre de la musique quand
- il n'y a pas de PlayOnRoomLoad
- Enters room after fade-in / before fade-in / firts time enters / repeatedly executed ne fonctionnent pas
- la musique est présente dans l'onglet audio et fonctionne lors du lancement dans l'onglet
- on ne connaît pas la commande pour jouer la musique en boucle dans une pièce et qui soit liée à cette pièce ?

Merci d'avance ^^ (et désolée si il y a un re-post perplexe)


Dernière édition par Light Dragon le Sam 28 Fév 2015 - 18:22, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
Billbis
Disciple de la Grande Tasse Bleue
Disciple de la Grande Tasse Bleue


Nombre de messages : 1275

Date d'inscription : 10/05/2012


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Jeu 26 Fév 2015 - 21:00

Light Dragon a écrit:
- Enters room after fade-in / before fade-in / firts time enters / repeatedly executed ne fonctionnent pas
Cela devrait. As tu linké les fonctions du script aux event de rooms? Petit eclair jaune en bas à droite.
En gros, c'est aMaMusic.Play() dans le room before fade in, et aMaMusic.Stop() dans le Leaves room.
Bon courage !

_________________
Mon petit DevBlog
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nothingaboutthedog.blogspot.fr/
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Jeu 26 Fév 2015 - 21:55

Ca devrait, effectivement ... Et non, quand même pas perplexe



(Oui, le fond d'écran est ... lâchement repris d'ailleurs ^^")
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
Kitai
Délégué de la tasse bleue
Délégué de la tasse bleue


Nombre de messages : 2430

Date d'inscription : 01/08/2006


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Jeu 26 Fév 2015 - 23:42

Le problème peut aussi venir de la configuration audio. Essaye de choisir une option différente dans Built > Run configuration setup (ou quelque chose comme ça).

_________________
Ga is Ga
Vous pouvez consulter l'aide d'AGS 3.2 en français et contribuer à la traduction et à l'amélioration si le cœur vous en dit !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://admin.no.uchi.free.fr/dokuwiki-2008-05-05/doku.php
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Ven 27 Fév 2015 - 19:14

J'ai essayé différentes combinaisons mais non, ça ne fonctionne pas. Il m'a même ajouté quelque chose comme quoi la musique était introuvable ... Je n'arrive pas à retomber sur le message ...
"Unable to initialize your audio hardware.
[Problem: Failed to init MIDI music driver]"

En regardant sur le forum anglais, d'autres personnes ont eu le même problème, je vais voir si leurs solutions fonctionnent.
(Ils proposent de ..
1. fermer le lecteur audio Windows, qui peut interférer, ainsi les applications internet utilisant le son, comme certaines extensions FireFox
2. bidouiller le son DirectX et le mettre en "Full acceleration" (??)
3. faire comme tu disais en mettant le son, non plus sur "Default Direct Sound" mais sur "Default WaveOut Device"

Si ça peut aider quelqu'un d'autre ^^")

Edit :
1. Fermé de toute manière, donc pas eu de changement.
2. ... J'ai essayé le "dxdiag.exe" et ... J'avais pas de curseur à bouger. Donc je ne sais pas où ils sont allés chercher ça (peut-être la différence de version, ils sont à la 9, ici je suis à la 11)
3. J'ai essayé mais pas efficace.


Dernière édition par Light Dragon le Ven 27 Fév 2015 - 19:56, édité 1 fois (Raison : Tests divers)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
Kitai
Délégué de la tasse bleue
Délégué de la tasse bleue


Nombre de messages : 2430

Date d'inscription : 01/08/2006


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Ven 27 Fév 2015 - 20:10

À vrai dire ça fait longtemps maintenant, mais je me souviens qu'à une époque j'avais aussi constamment ce problème sur un PC portable. Je sais plus si j'avais réussi à résoudre le problème dessus ou non, mais ça pourrait être une incompatibilité matérielle. Est-ce que tu as des problèmes avec les musiques des autres jeux AGS ? Est-ce que tu as déjà réussi à lancer une musique sur un autre projet ?

_________________
Ga is Ga
Vous pouvez consulter l'aide d'AGS 3.2 en français et contribuer à la traduction et à l'amélioration si le cœur vous en dit !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://admin.no.uchi.free.fr/dokuwiki-2008-05-05/doku.php
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Ven 27 Fév 2015 - 20:47

Pas encore essayé d'autre projet. Je vais voir ...
Par contre, en jouant sur "Le Phare", pas eu de souci.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Ven 27 Fév 2015 - 21:00

Problème 1 : pas de musique, et pourtant il y a ce "unable to initialize audio hardware"
Problème 2 : avec un nouveau projet, une musique prise directement dans la partie "démo" d'AGS ... Ca fonctionne tout seul ... Essayé avec une musique personnelle convertie en Midi, ça fonctionne aussi.

Le premier projet doit me bouder pour une raison inconnue ...
En relançant le 1er projet : toujours pas de musique. Bon ...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
Billbis
Disciple de la Grande Tasse Bleue
Disciple de la Grande Tasse Bleue


Nombre de messages : 1275

Date d'inscription : 10/05/2012


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Ven 27 Fév 2015 - 21:55

Quel est le format de ton morceau de musique? Veux tu me l'envoyer que j'essaye chez moi? As-tu pris la version noMP3 de l'Engine AGS?

_________________
Mon petit DevBlog
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nothingaboutthedog.blogspot.fr/
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Ven 27 Fév 2015 - 22:14

La version ... ? Ca je n'en sais rien :x
Le format est en midi.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
hanakin
Cliqueur Amateur
Cliqueur Amateur


Nombre de messages : 488

Age : 51

Localisation : Angers

Date d'inscription : 12/09/2012


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Sam 28 Fév 2015 - 18:13

Il me semble avoir deja posté sur le meme probleme rencontré par un autre utilisateur:

regarde ici

Cela serait dù a un problème Hard sur le Pc
"Unable to initialize your audio hardware.
[Problem: Failed to init MIDI music driver]"

Impossible d'initialiser la carte audio , manque apparement le driver Midi de windows(ou pb de version , comptabilité)
a les joies de l'informatique perplexe

_________________
Ce qui est utile à beaucoup l'emporte sur les désirs du petit nombre. (Spock)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://dinomania.chez-alice.fr/index.htm
Light Dragon
C'est quoi la Tasse Bleue ?
C'est quoi la Tasse Bleue ?


Nombre de messages : 11

Age : 22

Date d'inscription : 26/02/2015


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Sam 28 Fév 2015 - 18:21

Déjà regardé, Hanakin. Et modifié par conséquent.

Le DefaultVolume était réglé sur -1. Ce qui me faisait bizarre et, par sécurité, je l'avais mis sur "0".
Je n'aurais pas dû T-T

Problème résolu, merci à tous ^^"
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://zenjinthala.overblog.com
Billbis
Disciple de la Grande Tasse Bleue
Disciple de la Grande Tasse Bleue


Nombre de messages : 1275

Date d'inscription : 10/05/2012


MessageSujet: Re: [résolu]Musique qui ne se lance pas   Lun 2 Mar 2015 - 10:47

grand sourire

_________________
Mon petit DevBlog
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://nothingaboutthedog.blogspot.fr/
Contenu sponsorisé




MessageSujet: Re: [résolu]Musique qui ne se lance pas   Aujourd'hui à 19:51

Revenir en haut Aller en bas
 
[résolu]Musique qui ne se lance pas
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Résolu] Musique des cheetahmen
» [résolu]Musique/Volume sonore en pause
» [Résolu ] afficher un personnage et insérer de la musique
» [Résolu]Cherche la musique "Rainbow Warrior" dans le repèr
» [Résolu] Recherche de la musique "Frantic".

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Adventure Games Studio fr :: CREATION DE JEUX :: Questions / Réponses-
Sauter vers: