Forum d'entraide à la création de jeux d'aventure
 
PortailAccueilFAQRechercherS'enregistrerMembresConnexion

Partagez | 
 

 URGENT : Problème d'animation

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
filoulefilou
Cliqueur Amateur
Cliqueur Amateur


Nombre de messages : 259

Date d'inscription : 24/05/2010


MessageSujet: URGENT : Problème d'animation   Mer 15 Oct 2014 - 13:25

Bonjour les amis,
J'ai un jeu à rendre bientôt (genre demain, ah ah) et j'ai un gros problème pour animer un personnage.

Voilà l'idée, je voulais mettre des animations à un Boss et donc mettre une variable temps et indiquer qu'a telle variable temps, il faut lancer l'animation, SAUF que l'animation ne doit pas être en eNoBlock, car le personnage doit pouvoir bouger pendant.

Voici le code que j'ai fait et en gros, l'animation ne se lance pas, elle reste bloqué sur la 1ere image.

Code:
function room_RepExec()
{

  ///cBOW c'est le nom du Boss///
 ///BowserT c'est la variable que j'utilise pour simuler du temps///
 
  /////Animation Boss////
  if(cBOW.Animating){}
 
  else{
  BowserT=BowserT+1;}
 
  /////Boule de feu////
  if(BowserT==20){
 
  cBOW.Animate(8, 5, eOnce, eNoBlock );
 
  }
 
  if(BowserT==100){
  cBOW.Animate(9, 0, eOnce, eNoBlock);
  }


  if(BowserT==200){
  BowserT=0;}

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Kitai
Délégué de la tasse bleue
Délégué de la tasse bleue


Nombre de messages : 2431

Date d'inscription : 01/08/2006


MessageSujet: Re: URGENT : Problème d'animation   Mer 15 Oct 2014 - 13:53

Est-ce que tu as bien utilisé la commande LockView avant d'utiliser la commande Animate ?

_________________
Ga is Ga
Vous pouvez consulter l'aide d'AGS 3.2 en français et contribuer à la traduction et à l'amélioration si le cœur vous en dit !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://admin.no.uchi.free.fr/dokuwiki-2008-05-05/doku.php En ligne
filoulefilou
Cliqueur Amateur
Cliqueur Amateur


Nombre de messages : 259

Date d'inscription : 24/05/2010


MessageSujet: Re: URGENT : Problème d'animation   Mer 15 Oct 2014 - 13:56

J'ai essayé une fois en écrivant

Code:
  if(BowserT>=20){
  cBOW.LockView(33);
  cBOW.Animate(8, 5, eOnce, eNoBlock );
  cBOW.UnlockView();
 
  }
 
  if(BowserT==100){
  cBOW.LockView(33);
  cBOW.Animate(9, 0, eOnce, eNoBlock);
  cBOW.UnlockView();
  }


Rien n'y a fait !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Kitai
Délégué de la tasse bleue
Délégué de la tasse bleue


Nombre de messages : 2431

Date d'inscription : 01/08/2006


MessageSujet: Re: URGENT : Problème d'animation   Mer 15 Oct 2014 - 17:39

essaie sans le UnlockView, et en ayant un LockView plus général (dans le chargement de la pièce du boss par exemple).

_________________
Ga is Ga
Vous pouvez consulter l'aide d'AGS 3.2 en français et contribuer à la traduction et à l'amélioration si le cœur vous en dit !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://admin.no.uchi.free.fr/dokuwiki-2008-05-05/doku.php En ligne
filoulefilou
Cliqueur Amateur
Cliqueur Amateur


Nombre de messages : 259

Date d'inscription : 24/05/2010


MessageSujet: Re: URGENT : Problème d'animation   Lun 27 Oct 2014 - 11:56

Visiblement, le problème vient du fait qu'il y ait plusieurs animations et donc sans le eBlock , toutes les animations se superposent fatalement. Chacune n'attendant pas sagement que l'animation d'avant se termine pour se lancer et ainsi de suite.

Et malheureusement, avec un Point'n'click classique, il est simple de mettre toujours un petit eBlock, or, dans un jeu dynamique type , jeu de plateformes, c'est plus compliqué.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: URGENT : Problème d'animation   Aujourd'hui à 17:19

Revenir en haut Aller en bas
 
URGENT : Problème d'animation
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Problème d'animation de combat...
» [Animation] 5 Centimeters per second
» Problème de son iPod ou autre MP3
» Problème pour Tester mon Projet -RPG VX- [Résolu]
» Problème Egret 2 + J-pac + Arcade VGA (agp)

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Adventure Games Studio fr :: CREATION DE JEUX :: Questions / Réponses-
Sauter vers: