Forum d'entraide à la création de jeux d'aventure
 
PortailAccueilFAQRechercherS'enregistrerMembresConnexion

Partagez | 
 

 [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Ven 4 Avr 2014 - 9:09

Bonjour,

Je suis en train de créer un dialogue avec une réponse qui n'apparaitra qu'après une certaine action. J'ai donc un dialogue avec 4 questions/réponses dont la N°3 est cacher (j'ai décoché la case "afficher")

Problème : la question 3 reste visible, mais c'est la 4 n'apparait pas  zarb c'est un bug ?
En fait, quelque soit la question, la case "afficher" ne semble pas être prise en compte  pleure 

Autre source d'inquiétude : dans le setting général, l'option permettant de définir le nombre de pixel entre les options de dialogue ne fonctionne pas non plus. J'ai beau mettre un chiffre, ça ne change absolument rien.

Je commence à flipper...  peur


Dernière édition par chefgeorges le Mar 8 Avr 2014 - 13:22, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Ven 4 Avr 2014 - 20:27

Précision : J'ai supprimé le dialogue buggé, je l'ai refait entièrement et là ça marche. Sauf que ça reste particulièrement étrange triste
Je n'ai pas encore testé pour faire apparaitre et disparaitre un dialogue suite à une action. J'espère que ça marchera aussi...

Par contre, l'option définissant le nombre de pixel entre chaque option ne fonctionne toujours pas. A un moment on parle "d’Interface textuelle", kézako ? ça a un rapport avec ce problème ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
Atavismus
Grand Cliqueur Royal
Grand Cliqueur Royal


Nombre de messages : 1589

Localisation : France

Date d'inscription : 27/01/2014


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Sam 5 Avr 2014 - 8:17

Salut chefgeorges, tu peux nous montrer un peu de code, qu'on voit comment tu procèdes stp ?

_________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://store.steampowered.com/app/367110/
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Lun 7 Avr 2014 - 9:42

Le code n'a rien de particulier, d'ailleurs j'ai solutionné le problème... sans comprendre pourquoi perplexe
J'ai relancer une partie en test, depuis le début, et là tout a fonctionné  zarb Pourquoi pas avant... mystère total triste

Mais après j'ai eu des galères bizarres, comme des objets qui subitement passaient devant le personnage.
Je me demande si ce n'est pas parce que j'ai utilisé une room-modèle. En effet, pour me simplifier la vie et gagner du temps, j'ai choisi de dupliquer la room (avec l'option "définir comme modèle"). Ça avait très bien marché une première fois (la 2ème scène dans le Bureau). Mais là, j'ai eu plein de bugs étranges...

Tout semble être rentré dans l'ordre, même si je suis un peu frustré d'avoir eu l'impression de devoir bricoler sans comprendre le pourquoi du comment perplexe

Mais c'est vrai que j'utilise une version beta 3.2.2  langue
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
Atavismus
Grand Cliqueur Royal
Grand Cliqueur Royal


Nombre de messages : 1589

Localisation : France

Date d'inscription : 27/01/2014


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Lun 7 Avr 2014 - 9:52

Tant mieux si c'est solutionné, mais ça reste très étrange...
Tu as modifié des baselines ?
chefgeorges a écrit:
Mais c'est vrai que j'utilise une version beta 3.2.2  langue
Ouh le vilain ! grand sourire
Ceci explique peut-être cela...
Kitai ou un autre aguerri auront peut-être des explications.
Pour ma part, je n'ai jamais utilisé de room modèle.

Bonne continuation quoi qu'il en soit : je crois qu'on est plusieurs à attendre ton jeu. clin d\\\\'oeil

_________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://store.steampowered.com/app/367110/
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Lun 7 Avr 2014 - 12:46

Puuuurée !  uh

Je crois que mes problèmes viennent depuis l'implantation d'une interface de sauvegarde/chargement (avec un tuto d'Asraroth). En fait, j'ai l'impression qu'au lieu de charger ma partie en prenant mes changements en compte, il charge la partie avec les scripts d'avant sauvegarde (étrange, mais à l'écran ça donne tout-à-fait cette impression!). Si je supprime toutes mes sauvegardes et que là je recommence depuis le début, ça semble fonctionner... GALÈRE :'(
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
Kitai
Délégué de la tasse bleue
Délégué de la tasse bleue


Nombre de messages : 2431

Date d'inscription : 01/08/2006


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Mar 8 Avr 2014 - 12:56

Je pense que ce n'est pas la première fois que quelqu'un rapporte que d'anciens réglages généraux persistent dans d'anciennes sauvegardes, alors qu'on les a changés entre-temps.
C'est un peu embêtant mais si c'est bien comme cela que ça marche, ça ne devrait pas poser de problème au futur joueur, puisqu'il ne commencera nécessairement à sauvegarder qu'une fois les réglages définitifs établis.

_________________
Ga is Ga
Vous pouvez consulter l'aide d'AGS 3.2 en français et contribuer à la traduction et à l'amélioration si le cœur vous en dit !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://admin.no.uchi.free.fr/dokuwiki-2008-05-05/doku.php En ligne
chefgeorges
Cliqueur Emérite
Cliqueur Emérite


Nombre de messages : 500

Date d'inscription : 01/02/2008


MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Mar 8 Avr 2014 - 13:21

Oui, d'ailleurs je viens de compiler une nouvelle version, et tout semble fonctionner normalement sourire
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://instagram.com/ichefgeorges
Contenu sponsorisé




MessageSujet: Re: [résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(   Aujourd'hui à 17:22

Revenir en haut Aller en bas
 
[résolu] Bug ? Fonction afficher/cacher pour dialogues... ne fonctionne pas :(
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Résolu]Recherche 3 personnes pour faire le répére du collectionneur
» [Résolu]Cherche un ami pour Skate jusqu'à la victoire.
» [Résolu] Comment afficher le nom des lieux où l'on se trouve à l'écran ?
» [IL-2/Matériel : Résolu] Réglage CG pour IL-2 1946
» [résolu]Battre le Nargacuga pour passer rang 8

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Adventure Games Studio fr :: CREATION DE JEUX :: Questions / Réponses-
Sauter vers: